如何强制python只导入特定版本的OpenCV?

2021-09-16 23:58:37 发布

您现在位置:Python中文网/ 问答频道 /正文

我需要安装一个特定版本的OpenCV。在导入阶段我该怎么做?你知道吗

我见过一些人在其他软件包上使用这种方法,我尝试为opencv进行复制,但没有成功。。。这种方法的正确说法是什么?。。。你知道吗

import pkg_resources

pkg_resources.require("OpenCV==3.3.1")

import cv2
print('OpenCV version: ', cv2.__version__)