用现有的Python dis安装热情的Python发行版

2021-03-01 02:01:55 发布

您现在位置:Python中文网/ 问答频道 /正文

我目前正在尝试安装热情的Python发行版(EPD),并拥有现有的Python发行版。我目前已经安装了ipythonnumpy和许多其他工具,还有Sage(一个开源的Python科学/数学发行版)。在

当我尝试安装EPD时,我尝试使用EPD中包含的ipython从{}测试它。这给了我一个错误。如何使EPD成为默认的python发行版?

我的$PATH是:Users/scott/.zcm/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin:/opt/X11/bin:/usr/texbin

我的$PYTHONPATH当前为空。在

编辑:我还安装了ZSH,正在运行一台Mac,还有一大堆东西。原来问题出在ZSH身上。在我的.zshrc中,我必须加上这个:export $PATH=/Library/Frameworks/EPD64.framework/Versions/7.3/bin:$PATH这个/Library/...是在^{的其余部分之前添加的。在

1条回答
网友
1楼 ·

我还安装了ZSH,正在运行一台Mac,还有一大堆东西。在

原来问题出在ZSH身上,在我的.zshrc中,我不得不添加以下内容:

export $PATH=/Library/Frameworks/EPD64.framework/Versions/7.3/bin:$PATH 

/Library/...被添加到$PATH的其余部分之前。在

相关问题