SQLAlchemy Python 3 Ubuntu 16.04

2021-05-13 14:14:10 发布

您现在位置:Python中文网/ 问答频道 /正文

我似乎无法在python3中安装最新版本的SQLAlchemy。在stackoverflow上提出的类似问题都是在2016年之前,并且都在讨论Ubuntu的旧版本,因此这个问题再次出现。在

系统

  • Ubuntu 16.04
  • python2.7.12(如果我在终端中调用Python,则默认)
  • Python 3.5.2版

试过了

如果按照文档(http://docs.sqlalchemy.org/en/rel_1_0/intro.html#installationpip install SQLAlchemy中的说明操作,它只会将自己安装到python2.7(sqlalchemy.__version__:1.0.15)中。在

pip install python3-sqlalchemy不存在。在

sudo apt-get install python3-sqlalchemy在Python3中安装SQLAlchemy,但是sqlalchemy.__version__给出了1.0.11

问题

如何将SQLAlchemy的最新版本放入Python3目录,最好不要从源代码构建?在

2条回答
网友
1楼 ·

使用virtualenv:

pyvenv env
source env/bin/activate
pip install sqlalchemy

命令pyvenv创建基于python3.x的virtualenv

网友
2楼 ·

pip仅用于安装python2包。要安装python3的PyPI包,需要使用pip3

pip3 install SQLAlchemy

相关问题