如何安装seaborn的最新版本

2022-09-28 20:22:34 发布

您现在位置:Python中文网/ 问答频道 /正文

我想使用seaborn软件包创建catplot,我知道为了能够做到这一点,我需要seaborn的最新版本(0.9.0)。我使用以下方式安装了conda的软件包:

 conda install seaborn 

但它下载了0.8.1版

因此,我使用pip安装了我想要的版本:

 pip3 install seaborn==0.9.0

但每次运行代码时,我都会遇到相同的错误: 属性错误:模块“seaborn”没有属性“catplot”(该属性仅在最新版本中可用)

有人能帮忙吗


Tags: 模块installpip代码版本属性错误方式pip3seaborncondacatplot
3条回答
网友
1楼 ·

显然,康达尚未将seaborn 0.9.0整合到其默认频道中。您仍然可以尝试通过conda-forge获得它

conda install -c conda-forge seaborn 

您还可以在正在使用的conda环境中使用pip

> activate
(base) > python -mpip install seaborn==0.9.0

Anaconda发行版的当前版本已经安装了seaborn,因此conda update seaborn将在默认/可用的conda频道上将包更新为当前可用的版本。所有包都可以用conda update --all更新

conda update --name env seaborn将更新特定的环境,在本例中env

conda install --name env seaborn将安装到特定环境

conda update --name env --all将更新seaborn和所有其他软件包

不建议使用pip安装conda环境中已经存在的软件包

网友
2楼 ·

我是海本0.8.0。这对我有用

sudo -H pip install seaborn==0.9.0
网友
3楼 ·

这对我很有用:

conda install -c anaconda seaborn

信用证:https://anaconda.org/anaconda/seaborn

热门问题