无法安装包(pythontwisted),因为python版本不匹配

2021-05-16 08:03:26 发布

您现在位置:Python中文网/ 问答频道 /正文

这个错误几乎把我逼疯了!你知道吗

在安装twisted时,出现了一个错误,我的终端告诉我:

Processing Dependency: python = 2.6.6-64.el6 for package: tkinter-    2.6.6-64.el6.x86_64
--> Finished Dependency Resolution
Error: Package: tkinter-2.6.6-64.el6.x86_64 (rhel)
       Requires: python = 2.6.6-64.el6
       Installed: python-2.6.6-66.el6_8.x86_64 (@rhel-6-workstation-rpms)
           python = 2.6.6-66.el6_8
       Available: python-2.6.6-64.el6.x86_64 (rhel)
           python = 2.6.6-64.el6

当我把我的东西放进/usr/bin时,它会显示:

[root@dhcp-128-69 bin]# ls -l python*
-rwxr-xr-x. 2 root root 9032 Aug  9 18:12 python
lrwxrwxrwx. 1 root root    6 Nov 23 14:35 python2 -> python
-rwxr-xr-x. 2 root root 9032 Aug  9 18:12 python2.6
-rwxr-xr-x. 1 root root 1418 Aug  9 18:12 python2.6-config
lrwxrwxrwx. 1 root root   16 Nov 23 14:38 python-config -> python2.6-config

作为补充:

[root@dhcp-128-69 bin]# python -V
Python 2.7.10

那么,如何使用python-2.6.6-64呢?你知道吗

或者任何能让我成功安装的方法?你知道吗