运行spyd时未找到qtsvg的匹配分发

2021-11-29 23:34:25 发布

您现在位置:Python中文网/ 问答频道 /正文

我用python2.7.6安装了ubuntu14.04.5lts,我刚刚用pip安装了spyderIDE。然而,当我运行它时,我得到以下警告(从我发现它们是好的),但到目前为止,我无法解决它们。此外,我还收到一条错误消息,它阻止spyder运行。详情如下:

警告信息:

 RuntimeWarning: numpy.dtype size changed, may indicate binary incompatibility. Expected 96, got 88

我尝试卸载一些库并重新安装它们,比如(numpy、scipy、pandas、tensorflow和keras),但仍然出现相同的错误。你知道吗

下面是错误消息,这是关键:

  Could not find a version that satisfies the requirement qtsvg (from versions: )
No matching distribution found for qtsvg

我试图安装qtsvg,但再次出现相同类型的错误。那么这个问题的解决方案是什么呢?你知道吗