Python中文网

一个关于 编程问题的解答网站.

有 Java 编程相关的问题?

你可以在下面搜索框中键入要查询的问题!

java看起来像安卓 studio无法从依赖项中找到类

我想为我的应用程序创建设置片段,所以我在构建中添加了偏好依赖项。格拉德尔

def preference_version = "1.1.1"
    implementation "安卓x.preference:preference:$preference_version"
    implementation "安卓x.preference:preference-ktx:$preference_version"

但是当我想在XML布局中使用这个库中的任何类时,比如

<PreferenceScreen
    xmlns:app="http://schemas.安卓.com/apk/res-auto">

    <SwitchPreferenceCompat
        app:key="notifications"
        app:title="Enable message notifications"/>

    <Preference
        app:key="feedback"
        app:title="Send feedback"
        app:summary="Report technical issues or suggest new features"/>

</PreferenceScreen>

我发现了一些错误:

  • 无法解析类首选项屏幕
  • 无法解析类SwitchPreferenceCompat
  • 无法解析类首选项

我尝试在使用/gradlew clean之后构建项目,但没有任何帮助,我尝试使用不同版本的依赖项,不同版本的gradle,多次使用不同配置的java依赖项和kotlin依赖项,但没有任何帮助。奇怪的是,在XML文件之外,一切似乎都很好,我可以很好地使用这个库中的类,但我需要使用PreferenceScreen类进行布局,它无法识别它


共 (0) 个答案