有 Java 编程相关的问题?

你可以在下面搜索框中键入要查询的问题!


共 (6) 个答案

  1. # 2 楼答案

    Anyone has success of running applet page below with IE installing the jre7u25?

    我不使用Windows,但我肯定有人用过。至少对于IE的部分版本而言,它(坦率地说)在绝大多数情况下都不起作用是不可信的

    请具体说明您正在谈论的Windows和IE的版本,以及它如何“不适用于”您

    Are there any way to disable update of java when using runapplet(jnlp) below?

    这没有道理。JNLP不更新Java


    Java和IE10的问题似乎与32位和64位有关。显然,IE10默认在32位模式下运行,即使在64位平台上也是如此。32位浏览器需要32位Java插件

    • 检查实际安装的Java版本
    • 尝试将IE10切换到“增强保护模式”,看看它是否能找到64位Java
    • 尝试手动安装32位Java

    参考:

  2. # 4 楼答案

    64位java插件与增强保护模式不兼容,这是他们为IE10和IE11提供的一种新型沙盒

    因此,禁用增强保护模式,安装32位JRE,现在IE应该为每个窗口运行32位子进程,这将与32位Java插件兼容

    这对Win8中的桌面模式IE有效。新的平面非直观模式IE增强了保护模式的默认启用。您可以使用Process Explorer进行检查,并显示完整性列。如果显示“AppContainer”,则使用EPM

    希望这有帮助

  3. # 5 楼答案

    我的小程序也有问题。在谷歌Chrome中,从一开始就可以完美运行。 自动升级后,Internet explorer 10似乎无法识别PC上安装的新Java 7 u 25。 我通过以下步骤解决了这个问题:

    1. 在PC上卸载所有Java 7版本

    2. http://www.oldapps.com/java.php上下载Java包(取决于您需要的32位或64位)

    3. 安装Java

      在这之后,IE10认可Java和小程序工作正常

  4. # 6 楼答案

    我能让最新的java(7 update 25,32位)一直在Internet Explorer 10桌面模式(Windows 8 64位)下运行的唯一方法是创建一个新的快捷方式:

    “C:\Program Files(x86)\Internet Explorer\iexplore.exe

    然后点击高级(在快捷方式中)并选择以管理员身份运行

    如果你不想这样做(出于安全原因),我发现的解决方法是安装Chrome(因为Java一直在工作),并将其用于需要Java的站点

    我希望这能有所帮助